Design Solutions:

Actions in Adobe® Photoshop®

We all know that Photoshop can suck up your time better than any vacuum.
If you want to spend more of that time working creatively you want to add

Actions to your tool set.

How can actions help you?
Consider the work you do in Photoshop.
'There are probably certain steps that you're
repeating for each image. Even if it’s just
a step or two, they can add up to a lot of
time and mouse clicks. By recording actions
for these tasks you can spend more time
working creatively. Actions can be run on
individual files, or on whole folders of files
by using the Batch or Image Processor
commands in either Photoshop or Adobe
Bridge. Using Bridge you can even run an
action on selected files (instead of a whole

folder.)

'There are dozens of actions available for
tree download on the Web. We're going to
show you how to create your own actions
for those everyday tasks.
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Start with a test run

“Plan ahead” has always been good advice.
Sure, it takes a couple of minutes to set up
an action. And it makes you take a good
look at your workflow. In the end, this
will allow you to work more efficiently.
Typically you'll have more luck if you walk
through the steps that you want to record
before you record them.

Create an Action

In our first example we will create an action
that adds a Curves adjustment layer and
applies the Auto setting.

Make sure you have a file open

When you create an action you are instruct-
ing Photoshop to record your steps. You
don’t typically want to record the step of
opening a particular file. Youre going to
want to run the completed action on a file
that is already open or a whole bunch of
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files. We want to make sure we have a file
open before we create our new action.

Display the Actions panel
Choose Window > Actions to display
the Actions panel. (Observe the folder of
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Default Actions. You may find something
there you didn't realize you needed.)

ADIJUSTMENTS

using Levels, you can choose Layer > New
Adjustment Layer > Levels instead.)

Curves | Drefault Ii]
Create a new action res v| (oo Save
Click the folder icon to create a new action & Choose File > Save As and save your file
set for your actions. You can name it [your # with a new name.
namel’s Actions. Then click the Create new *

action icon to create a new action. We'll
name it Auto Curve. Observe that you can

Stop recording
Click the stop recording button. That’s it!

— —

New Action
e MD_ chg Actions and Saving
Sat: | Patti's actions M [ Cancel | — y .
. || You'll notice tha.t we added a Save As com-
@ mand to our action. If you run the action
Colar: | [ Mone M - . .
=5 on multiple files using the Batch command
E it must have a Save command or none of
apply a color and a keyboard shortcut to et et your files will be saved. However, if you're
the action. Click OK. Photoshop is now S e e > 0 B running the action on a single file you won't
recording every step you take. want the Save command—it will just over-
write the file that’s there, so you'll check
4. Step by step the box next to the Save step to turn it off.
For our action we will choose Layer >
New Adjustment Layer > Curves. Then
we'll click the Auto button to apply the Use the action
Auto settings. (If you're more comfortable You can use the action you just created on
an open file, on a folder of files, or if you
<= use Adobe Bridge—on selected files.
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Run the action on a single file Batch
. . — Pl
With a file open, select your action from o (oot sciome 5 o]
the Actions panel. Uncheck the Save step st
Cction: | Auto Curve M

so that it won't save to the name and loca- o
tion you choose earlier. Click the play but- '
5 . Ch\Documents and SettingshpdsokoliDesktophactions\correct?,

ton. Don’t blink! Clovermds Actin “opart

Cwerride Action “Open” Commands
[Cinclude &I Subfolders
[CIsuppress File Open Options Dialogs
[suppress Colar Prafle Warmings

C:\Documents and Settings\pdsokal Desktoplactions\correct\New Folder),

About the Batch dialog box
Let’s take a look at the Batch dialog box.

In PhOtOShOp, choose File > Automate > [¥]override Action “Save As” Commands
Batch — File Marning
: Exarnple: MyFiea.gif
R . |D0cument MName M+| a v+
It’s pretty straightforward, choose the =
. K extension M+| v+
action set and action that you want to play. | | &
Choose your source folder. S
Comnpatibility: windows [IMac 05 [JUnix
If your action includes an open command _
you'll want to check the box to Override [ Eors
Action “Open” Commands. (Remember, we S8 A
started with an open file so there wouldn't
be an open command recorded. Therefore, Choose the destination folder. Check the You have all sorts of options for naming the
we should not check this box.) Check the box to Override Action “Save As” Com- file, including serial numbers and date.
boxes to suppress open options dialogs and mands. Again, we needed to record the
color profile warnings. Save As so that the file will get saved, but
we want the Batch dialog box settings to
<= control location and file name.
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Run the action on multiple files

'There are a couple of methods available for
running an action on multiple files. From

within Photoshop you can choose:

» File > Automate > Batch or File > Scripts

> Image Processor.

» From Bridge you can choose Tools >
Photoshop > Batch, or Tools > Photo-

shop > Image Processor.

'The Image Processor allows you to run the
action while changing file type or resolu-
tion. Using Bridge offers the benefit of
allowing you to select specific files and run
the Batch or Image Processor commands

on the selected files.

Practice—Apply a custom curve
adjustment to multiple files

Let’s take the next step. Suppose that you
have several images that were shot under

the same lighting conditions. Perhaps in
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a studio or even outdoors. Wouldn't it be
great if you could apply a custom Curves
adjustment to all of the images?

You'll begin by correcting one image and
saving a Curves Preset.

Open one of the images and add a
Curves adjustment layer

Use the black point and white point eye-
droppers to adjust your image. Click with
the black point eyedropper in the area of
your image that should be black. Click with
the white point eyedropper in the area of
your image that should be white. Drag the
curve if further adjustment is needed.

Save a Preset

When the image is adjusted to your liking,
choose Save Curves Preset from the Curves
panel menu. Give the Preset a meaningful
name.

Create the Action

Now create a new action using the same
steps we followed before. This time instead
of clicking Auto choose Load Curves Pre-

set from the Curves panel menu. Remem-

ber to save the file. Run the action on the

group of files.

More options

Let’s explore the other options available to
us in the Actions panel.

Edit an action

What if you want to change a value that
you entered when you were recording the
action? It’s easy, simply double-click on
that step in the action and change the value.

And if you want to add a step or two?
Select the step in the action that the new
steps will follow and click the Record but-
ton.

Delete a step by selecting it and click-
ing the trashcan icon at the bottom of the
Actions panel.
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Turn off a step

Let’s say you want to run all of the action

except one step. Simply click the check
mark next to that step to turn it off.
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Prompt for input

What if you want to be able to enter a
custom value in a dialog box? You can set
your action to display a dialog box when

it gets to that point. This is called a modal
control. (See the screen shot on page 1.) The
easiest way to do this is after you have
recorded the action. Simply click in the
second column next to that step. You'll see
an icon that represents a dialog box. Be
aware, if you click in the second column
next to the action name you will be setting
that behavior for all the dialog boxes in the
action. You’'ll be warned that this cannot be
undone. You can always turn each one off,
manually, one... at... a... time.

Insert a stop

Whether you plan to share this action

or not, communication is a good thing.
Choose Insert Stop from the Actions panel
menu to type a message that will appear

at that point in the action. Be sure to click
the Allow Continue button so that you (or
someone else) can continue running the
action.

Button Mode

Button mode is for those of you who would
like to be able to run an action just by click-
ing a button. Choose Button Mode from
the Actions panel menu. Remember that
you chose a color when you created your
action? That shows up now. To change the
color or keyboard shortcut turn oft Button
Mode, select the Action and choose Action
Options from the Actions panel menu.

Practice—Record an action with
multiple steps

Let’s record an action that has more than
one step. We'll record an action that adds



Actions in Adobe® Photoshop®

canvas to our image, puts a black outline

around it, and finally adds a drop shadow.

Before you begin

Stroke
— Stroke Lok ]
width: | 10/px]
Calar: -

Canvas Size
— Current Size: 320.2K [ o ]
width: 5.597 inches

Height: 4,472 inches

— Mew Sizen 547.9K
width: | 120

perent ]
perent ]

Height: | 120]
[CIRelative

Anchar: Y + A

[+
A1 [

Canwas extension color: | Background ]

Make sure you're working with an image
that has a single layer named Background.
Set your foreground and background colors
to their defaults of black and white.
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— Location

O1lnside Ocenter & Outside

— Elending
Mode: | Morrnal M

Opacity: | 100 Yo

Create a new action
Name it Shadow Frame 10 px and save it
in your actions folder. Click OK. You're

now recording.

Duplicate the Background layer
Right-click on the word Background in
the Layers panel and choose Duplicate
Layer. You can name the layer or accept the

default of Background copy.

Add canvas

Choose Image > Canvas Size. I like to
change the units from inches to percent.
‘That makes the action useful regardless of
the original image size. Let’s set both the
width and the height to 120 percent. Make

—
Layer Style
— Structure
Blending Options: Default Elend Mode: Mty E
[“]Drop Shadow —— = -% _NEW —
[inmer Shadow 3 __
Angle @ []use mlobal Light [] Preview
[l outer Glow el @ Ell se @lobal Lig
[ anner dlow Distance: . o
[JBevel and Embass Spresd: 3 [g % .
[ contour Sizet (}— g @
[ Testure p—
[ satin
Contour: [ anti-shiased
[ Colar cnverlay
[ Gradient Qwerlay Moise: 3—————— |0 %

[strake

[CIPattern werlay

[¥]Layer knocks Gut Drop Shadaw

sure the center square is selected for anchor
position.

5. Add the stroke
Make sure that Background copy is the
active layer. Choose Edit > Stroke. Set a
stroke width (I chose 10 px) and then click
to set the Location to Outside.

6. Add the drop shadow

With Background copy still active, choose
Layer > Layer Style > Drop Shadow. Turn
on the preview and modify the settings
until you're happy with the result.
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Save and stop recording

In the old days I'd probably flatten the
image. But these days I prefer to maintain
the editability of the drop shadow eftect.
So we'll choose Save As and give it a name.
'Then click the stop recording button. You
can now run that action on any image

that you'd like to have a border and a drop
shadow.

Final tips

Don’t assume. Be sure that your starting
image is what you expect. For example, if it
already has multiple layers you might get an
unexpected result.

Keep it simple. It may be easier to run one
action and then another than to write one
long complex action.

Use the History panel. The History panel
can help you troubleshoot your action.
Remember that by default the History
panel only keeps track of the last 20 steps
you performed. If you need to see more
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change the settings in the Preferences
menu.

Use Bridge to run an action on selected
files (rather than a whole folder.) Use the
Filter panel to help you select the images.
Use the Image Processor to resize, output
to different format, and run an action all at
the same time.

Look online for lots of free actions. Start by
checking out the Photoshop Exchange.

http://www.adobe.com/exchange

You can also check out the links on my

Delicious page:

http://www.delicious.com/pdsokol

Respectfully submitted,
Patti D. Sokol, Instructor
www.sokolconsulting.com

CERTIFIED INSTRUCTOR
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